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 Warning!
It is  essential that you read and understand this  entire manual, the Product Manual(s) for all devices 
connected with Modbus  or drive.web and the entire contents  of the savvy software “Help” menu 
before proceeding with your installation and product configuration. For more information and copies  of 
product manuals and software, go to www.driveweb.com.

 Warning!
Your use of savvy software, drive.web devices with Modbus may cause motors  and machinery to 
power up with high voltages or start or operate in an unexpected, dangerous or lethal way. It is  essential 
that you are completely familiar with savvy and all of the equipment and the system design you are 
working with before attempting to program or edit a program or connect to any live device.

 Warning!
You are entirely responsible for the configuration or use of any drive.web product. By configuring or 
using these products you agree to indemnify and hold harmless  Bardac Corporation, its’ employees, 
directors, officers, distributors  and resellers  against the consequences  of your configuration or use of the 
products.

speedy485  Features
Add interface, intelligence, and internet and systems connectivity to any 
ModbusRTU enabled devices:

Generic ModbusRTU Master, dw117 and dw121.

Invertek Optidrive Plus and VTC with dw118 and dw121.

Yaskawa YF7 with dw119 and Yaskawa V1000 with dw120.

drive.web distributed process control over Ethernet

Modbus TCP/IP Slave Ethernet enabled slave/server included.

Easy upgrades with savvy software. See page 6.

System libraries; Basic and Optional; Process, Winder and Math.

Function Blocks; Complete drive control and monitoring with 
dw118-120, Math, logic, PID, comparator, filter, latch, timer, 
counter, ramps, winder diameter, taper tension, torque 
compensator, more.

For information on Modbus specifications go to http://modbus.org/specs.php
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speedy485 Base Models
dw117 speedy485 controller with ModbusRTU Master or Client, 

EIA485 via standard terminal block, up to 115kbps.

dw118 speedy485-o Control your Invertek Optidrive Plus with 
dedicated serial link and complete, illustrative parameter control and 
monitoring. 0.3m serial cable included. Longer cables available.

dw119 speedy485-yf7 Control your Yaskawa F7 Drive with 
dedicated EIA485 serial link via a standard terminal block. 
Complete, illustrative drive parameter control and monitoring.

dw120 speedy485-v1000 Under Development, Please Call.

dw121 speedy485-6p6c controller with ModbusRTU Master or 
Client, EIA485 via convenient 6P6C RJ jack, up to 115kbps.

speedy485 Options
Software Options 05, 06, and 10 may be added using savvy. See Upgrading, page 6.

See savvy User Manual, Appendix A for complete listing of  available function blocks.

05 Process Control. Function Block Library 1 - Math, Logic, PID, Switches, 
Comparators, User data log, Profiler, Presets, Latch, Filters, Counters, Timers, more. 

06 Winder Control Function Block Library 2 - Diameter Calculator, Taper Tension, 
Torque Compensator.

10 Advanced Math Function Block Library 3 - Trig, Polynomials, Log, Exponent, more. 

speedy485 Winder Specials 
Include options 05 and 06 and pre-installed winder system configuration 

1101 speedy485 winder 1  Open Loop Constant Tension Center Winder. 

1102 speedy485 winder 2 Closed Loop Dancer Control Center Winder. 

1103 speedy485 winder 3 Closed Loop Loadcell Control Center Winder.

speedy485 Installation
Warning!   Dangerous, High Voltages that may cause injury or death are 
present on drives, motor controllers and other industrial devices! 

Only qualified personnel who are completely familiar with the device that the 
speedy485 will connect to should proceed!

Dimensions and Weight: 4.25”(dw117, dw119 4.7”) x 1.8” x 1.15” (107(119) x 46 x 30 mm). 3.4oz(97g).

Power Requirement: 24VDC ±15%, ~50mA, ~1.2W. 

Storage and Operation Environment: Clean air, Temperature range; 0 to 50C. 

Humidity less than 95% non-condensing.

Ethernet Port Standard “RJ45” 8P8C, 10BaseT, Link and Activity LED’s

Mounting: Adhere the speedy485’s  self-adhesive hook and loop strip on or near the 
drive or EIA485 device.  Be careful not to obstruct any air vent holes  or access  points 
and do not obscure any product labels.  Do not attach the speedy485 near any hot 
spots such as heatsinks, cooling fans, etc., nor near to drive power terminals.
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speedy485 Installation continued...
Wiring Notes All signal wiring should be twisted-pair. All wiring outside of the metal 

enclosure should be shielded cable with individually shielded twisted-pairs  such as 
Belden 8163.  Ground the shield at only one end with a 360° clamp where the shield 
enters  your metal enclosure. Separate all wiring from RF noise sources  and AC power 
cabling. 

Terminal Definitions:
	

A and B must share a single twisted pair. C may use one or both conductors  in another 
pair. Do NOT pair C with any other signal.

EIA485 Common Reference is  required. It is  named C so that it is  not confused with 
other common, ground or shield connections.  

dw118 Set up Your Optidrive Plus
Check your model number and firmware revision. P0-28 and P0-29 should 
indicate 2.2 or higher. Model number must end in -M for firmware revisions less than 3.0.

Check that baud rate and drive communication address are at default settings.  
P2-26 must be 115.2 kbps and P2-27 must be 1.  

If your ODP is  part of an Optibus network, use the Data Cable Splitter, OD485SP-IS 
to allow communication with your speedy485. The speedy485 will only 
communicate with the master.

dw119 Set up Your Yaskawa yf7
Check parameter U1-14, Flash ID = 3020. This is currently the only supported software.

Connect the terminals, S- and R-, together for EIA485- or A.  Connect S+ and R+ 
together for EIA485+ or B connection. 

Set the baud rate at parameter H5-02 to 4 for 19.2 kbps.

Check the Modbus Unit address, Parity and Delay times are at default settings:  

H5-01 = 1F = Address, decimal 31

H5-03 = 00  No Parity

H5-06 = 05  Minimum delay, 5ms 

Set H5-04, Stopping Method and H5-05, Serial Fault Detect to set drive response to serial coms loss.

Important Note:  You must cycle the YF7’s  power, waiting for the screen to blank 
before re-powering, in order for the changes to take effect.
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dw118, dw121 with 
6P6C Connector

dw117, dw119 and dw120 with 
Pluggable Terminal Block

0V    24V

C
A
B

1
2
3
4

Terminal EIA485 Name Modbus Name Description
A A or Data − D0 Inverting Pin
B B or Data + D1 Non-Inverting Pin
C SC or Data 0V Common Common Reference

1.  B, EIA485 +
2.  0V
3.  +24VDC
4.  NC
5.  NC
6.  A, EIA485 -



speedy485 Ethernet Networking & Programming
Before proceeding, it is  important to have a basic understanding of Ethernet TCP/IP 
networks. Assigning an invalid or duplicate IP address  will cause serious  network 
malfunctions! speedy485s  are shipped with the same IP address, 10.189.189.189. 
Consult your company’s IT department for an appropriate, unique IP address.

Find useful networking information, under the Help menu, click on User Manual. 
Scroll down to the Basic Network Administration section. 

Set up Your Physical Ethernet Network - You Will Need:
A standard Category 5e cable with 8P8C/RJ-45 connectors on both ends for each 
drive.web  device and your computer.

For systems with more than one drive.web device, an Ethernet switch with ports  for 
all drive.web devices and your computer.

Set up Your Computer - Get savvy
With free drive.web savvy software, easily program and monitor your speedy485, 
perform data trending and create distributed control systems.

To download the latest version of savvy and to view the savvy user manual, go to 
www.driveweb.com and click on Get savvy.

Java Runtime Environment must be installed to run savvy. There is  a link on the 
Get savvy page to download Java for free. 

If you do not have internet access, install savvy and Java from the Bardac Infodisk. 
Browse to the savvy link, off-line installation. Contact us for the files or Infodisk.

Get started with savvy
We strongly recommend you attend our free on-line training seminars. To register, 
e-mail training@driveweb.com or call.

Before proceeding with your systems designs it is  very important to familiarize 
yourself  with savvy, the configuration software. 

We strongly recommend you read the introductory guides under the Help menu; 
Getting Started with savvy, Getting Started with savvy-SFD, savvy-SFD 
and the PL series drive.   

Use Create Phantom in the Directory menu to practice, explore all drive.web 
products and options and design and configure off-line. Design systems in Phantom 
devices  and Export Data under the Directory menu for later use in live devices. 
Import Data into  phantoms to work off-line. 

Under the Directory menu, click Discover All Local Devices. If your speedy485 
is powered and on the same local network as your computer, an icon should appear.  

Discover drive.web devices  anywhere on the internet unless  they are protected by 
firewalls  or other network security devices. Assign a public IP address  or use a VPN. 
Under the Directory menu, click on Discover Device...  

If the icon at right appears  with the red padlock and comms-fail indication, a network 
connection problem exists. Check connections, LEDs and that the speedy485 IP 
address is within your computer’s subnet mask.  

Warning! Changing a device IP address  WILL disrupt its network connections! If a 
speedy485 is  communicating with other devices  or drives  you must be prepared for 
system disruption and to remap connections  in those devices  when changing an IP ad-
dress. In the File menu choose Utility > Remap Export File to remap a dw-system 
file with different IP address(es).
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Get started with savvy continued...

Under the File menu, click Administrate > Set IP Addresses for System.  Locate 
the serial number on the product label of your speedy485. Enter a unique IP 
address  that is  within your computer’s  subnet mask and click OK.  A speedy485 or 
a drive icon should appear with IP address beneath.  

If a drive icon appears with a question mark overlaid, the speedy485 is  not 
communicating with the drive. Check the drive power and serial port settings. See p.3

Hover cursor over a device icon, function block, connection or parameter to see 
contextual information in the status  bar at the window top margin and reveal the 
hover button.

Click a hover button or right-click an icon to access its contextual menu.

In the speedy485 contextual menu, choose Change Name to name your 
speedy485 for easy identification. Also, a powerful Find Parameter... function 
locates and jumps views to a parameter. Enter its number, name or partial name.

To Import or Export (load or save) configuration data to or from your speedy485, 
use its contextual menu.

To Import or Export all configuration and connection data to or from all drive.web 
devices and phantoms in the directory use Directory menu.

Advanced Users: At the bottom of the Setup IP Addresses window, click the arrow 
next to Network Information to set subnet mask and router IP addresses. See the 
savvy user manual. Note! If the Network Information box is  expanded, this 
network information will be set in the device(s) whose IP address(es) are changed.  

savvy views  are hierarchical with the Directory view at top. Use the navigation 
arrows  in the status bar to view the next higher level or go backward and forward 
through a series of  views. Note that menus change as you navigate. 

savvy function may be limited if you do not have the required capability level or a 
device is locked with a password.

Click the speedy485 icon to view the Overview screen (Standard savvy, no 
SFD). Click the Function Block Engine icon and if you have options  02, 04  or 12, 
the Modbus icon to view. 

In the Function Block Engine view (Standard savvy, no SFD), click the FBE menu 
and select function blocks  in the order that you want them to be processed. Processing 
order is from left to right, then top to bottom.

Click on a function block to view its parameters and functional detail. 

Connect between parameters and to parameters  in other drive.web devices  over 
Ethernet. Under the File menu, choose New Viewer... and then Open Device 
Directory. Now you can click on a parameter, drag a connection and drop onto a 
destination parameter in the other viewer.   

Use parameter contextual menus for Get Info, Add to Dock, Copy, Connect to… 
start or end connections, Re-name..., and Re-scale...

Click any blue connection to jump views to the other end.

Use connection contextual menus  in drive.web-over-Ethernet and FBE-to-drive 
connections to Change Sample Period… and prioritize connections. 

Click on parameters  to open the setter box. Adjust the value with convenient graphical 
buttons or keyboard entry.

Most drive.web parameters  use 16 bit words  allowing raw decimal integer values 0 
to 65535 or ±32767. These raw values  are formatted, limited and scaled depending 
on the parameter.  Use Get Info or Re-Scale to verify or change.
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A1 speedy485

Get started with savvy continued...

A blank rectangle connected to or from a parameter indicates  a remote device is  not 
discovered in savvy. 

Very complex function block configurations with numerous  Ethernet connections  may 
produce Timebase Overrun indications  at the System function block. Performance 
WILL be affected. In the System block contextual menu adjust the speedy485’s 
Timebase Setpoint. Make a connection from the Program Status parameter to 
log these occurrences or provide warning signals.

savvy with Signal Flow Diagram Option - SFD Upgrade
With savvy-SFD, build systems  graphically while creating live 
drawings that are stored in your speedy485.  

Set borders, drag and drop connections, zoom, pan, cross-
reference and annotate multi-page drawings. 

A separate function block and connection listing shows  program 
execution order from top down. Change execution order by 
dragging function blocks up or down the list. 

Upgrading savvy and speedy485
Process  a credit card or Vouchers on-line or purchase Coupons for use off-line. Find 
the Shopping Cart under the Commerce menu.

Select Upgrade savvy under the Commerce menu.

Right-click on speedy485 icon and choose Upgrade Device…

To process  Vouchers choose Pay>Online Via Vouchers in the Shopping Cart. 
Enter each Voucher code on a separate line.

Process  Coupons in the Coupon Manager, under the Commerce menu. Enter 
individual codes  in the top box and click the Add button. The Coupon is  recognized. 
Click Apply.

speedy485 Option 04 ModbusTCP/IP Slave/Server
Supports  up to three simultaneous masters. Further connection 
attempts are refused until a connection is ended. 

Supports Modbus Function Codes 03 and 16

Adheres to Modbus Conformance Class 0

You cannot write or force parameters  that are read-only or have in-
coming drive.web connections.

ModbusTCP Slave Port 502 is  the standard specified in the protocol. You may 
change this to match the master in the unusual case that it is non-standard.

Modbus Indirect function blocks  with sequentially numbered parameters  make best 
use of Modbus  multiple read or write functions. Enter any parameter numbers  to 
read or write with one Modbus operation. 

Directly address  any numbered parameter individually. You are NOT required to use 
Indirect parameters.
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dw117 and dw121 Generic ModbusRTU Master
Supports Modbus Function Codes 03, 06 &16.

EIA485 allows multi-drops. One master or client device can poll many slave or 
server devices individually. 

Contact us  for technical manual HG502436 if: Your ModbusRTU device has no C, 
EIA485 Reference AND there is more than one slave. Trunks over 150 meters.

Correct multipoint topology is  single daisy-chain or trunk with a device at each end 
and additional devices  on short stub branches. Star, ring, or extended branch 
topologies are NOT recommended.

Line termination is  recommended between A and B at both physical ends  of the 
trunk or chain, NOT at any branches  or links. Do NOT provide line termination 
with any ODP, ODV or ODE2 AC drives.

ModbusRTU networks  only allow one master device but can support multiple 
servers. Transceivers are 1/8 unit loads.

Comms Port Function Block
Configure your serial port with the ModbusRTU Comms Port function block.

Comms Speed. Communications rate in bits  per second (b/s). Set between 300 bps and 
115.2 kbps. Must match the slave device's settings.

Comms Configuration. The character framing format is 8 Data bits-Parity-Stop bits. 

Supported character framing is: 
8-N-1 	 8 Data Bits, No Parity, 1 Stop Bit
8-O-1	 8 Data Bits, Odd Parity, 1 Stop Bit
8-E-1	 8 Data Bits, Even Parity, 1 Stop Bit 
8-N-2 	 8 Data Bits, No Parity, 2 Stop Bits

Actual Polling Period Read-only. Time in milliseconds, ms, 
required to poll all parameters  defined in all the Modbus 
Holding Register blocks. The period is  directly affected by 
the number of registers, comms errors, comms timeouts, and 
the comms sleep time. 
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ModbusRTU Master, Comms Port Function Block continued...
Comms Timeout. Time in milliseconds, ms, for the master or client to wait for 

a reply before moving to the next parameter in the polling cycle.
Range=0 to 30000 ms 

Comms Sleep Time. The time delay in milliseconds, ms, between the end of 
the previous  and the start of the next polling cycle. May be adjusted to limit 
microprocessor loading of the drive.web or slave device if serial link update 
performance is not a critical factor.

Status. Any of the Last Errors  of the individual Holding Register function 
blocks. All individual Last Error codes  can be cleared by clicking on the 
parameter and using the Reset button.

Enable. You may globally disable the serial 485 communications here. 

Holding Register INT16 or UINT16 Function Blocks
Define the data point and the slave or server device. Create 
multiple instances  of these blocks, one for each remote 
parameter. The Holding Register’s  Value parameter may have 
drive.web connections  to and/or from it, allowing read and/or 
writes to the remote parameter. 
Modbus Address is  the unique address  number between 1 and 

247 assigned to your slave or server device. 
Data Address is  the parameter identification number, PIN or 

register number in your server that you wish to read and/or 
write to/from. 

Enable allows  this  register’s comms  to be disabled to reduce polling periods. 
Make a drive.web connection to this block for dynamic control.  

Last Error records  the last error communicating to this  address. Click to reveal 
the Reset button.

Options: A check box for certain devices  that require function 06 instead of 16. 
There is  another check box for Yaskawa drives’ special Yaskawa Accept/
Enter function.

Value shows the value which is read/written to/from the remote parameter.

drive.web Product Line Overview
dw210 smarty with sixteen analog and digital I/O. Optional dual serial ports, 

dual encoder module, Encoder Control Library with various  shaft lock and 
position functions. 100BaseTX Ethernet. SNTP and SMTP support.

dw213 smarty-o with Optidrive Plus AC Drive serial link.
speedy sp Add drive.web power and connectivity and optional function block 

libraries, ModbusTCP and ModbusRTU to any PL-Series Digital DC Drive.
savvy-sfd Signal Flow Diagram Option see page 5.
speedy485 & all drive.web products are designed & assembled in the U.S.A.

Get expert drive.web help. Call or email techsupport@driveweb.com

drive.web Training Courses
Free drive.web online interactive training seminars take about one hour. 
Specialized online and factory training sessions are also available.  
To register email training@driveweb.com or call.
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Ph. 410-604-3400, Fax 410-604-3500, www.driveweb.com
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